Archive for the ‘Networking’ Category

‘telnet’ is not recognized as an internal or external command, operable program or batch file

Sometimes When you telnet to a particular port number you will get the below message

“‘telnet’ is not recognized as an internal or external command, operable program”

Untitled0

The message means that there is no telnet client installed on the machine from which you are tel-netting  , goto Program and features , Click turn windows features On or Off , Select Telnet Client Check-box and click ok to Install Telnet Client  . After that you would be able to telnet to a particular port

Untitled

 

Untitled1

Untitled2

Create VLANS on a 2950 Switch

vlan

 

create vlans on a switch

Switch# configure terminal

Switch(config)# vlan 2

Switch(config-vlan)# name engineering

Switch(config-vlan)# exit

Switch(config)#vlan3

Switch(config-vlan)# name marketing

Switch(config-vlan)# exit

Switch(config)#vlan4

Switch(config-vlan)# name accounting

Switch(config-vlan)# exit

Switch(config)# interface fastethernet0/2

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 2

Switch(config-if)# exit

Switch(config)# interface fastethernet0/3

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 3

Switch(config-if)# exit

Switch(config)# interface fastethernet0/4

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 4

Switch(config-if)# end

In this way all the port no 2 of the three switches will be in engineering vlan , all port no 3 will be in marketing vlan and all port no 4 in accounting vlan . All the machines in a particular vlan can communicate with each other even after being on different floors .

Configuring Static NAT and Dynamic NAT on a router

Static NAT

R1(config) # interface E0
R1(config-if) # ip address 172.168.30.8 255.255.255.0
R1(config-if) # ip nat inside
R1(config-if) # interface S0
R1(config-if) # ip nat outside
R1(config-if) # ip nat inside source static 172.168.30.5 200.0.0.0
R1# debug ip nat
R1# Show ip nat translation

Maps inside local IP 172.168.30.5 to Global IP 200.0.0.0

Dynamic NAT

R1(config) # interface E0
R1(config-if) # ip nat inside
R1(config-if) # interface S0
R1(config-if) # ip nat outside
R1(config) # access-list 1 permit 172.168.30.0
R1(config) # access-list 1 deny any
R1(config) # ip nat pool prashant 192.168.11.11 192.168.11.20 netmask 255.255.255.0
R1(config) # ip nat inside source list 1 pool prashant
R1# debug ip nat
R1# Show ip nat translation

The IPs from the network 172.168.30.0 will be translated and will be assigned IPS from the prashant pool dynamically.

(adsbygoogle = window.adsbygoogle || []).push({}); //--> Feedjit Flag Counter